1. Comment se connecter au switch

  2. Comment enregistrer la configuration

  3. Configuration de base

  4. Configurer ssh

  5. Configuration des ports

  6. Comment configurer les vlans

  7. Comment configurer simplement la qualité de service

  8. Comment configurer le spanning-tree

  9. Configuration des services syslog, snmp, ntp

  10. Comment mettre à jour le switch

  11. Configuration d'une pile de switch 3750

  12. Quelques commandes de diagnostique

  13. Routage intervlan





Configuration du spannnig-tree sur un switch Cisco.
Les commandes suivantes ont été testées sur des switchs série 3750 et 2960.

Pour rappel, l'objectif du protocole (défini par la norme 802.1d) est de gérer les boucles sur un réseau local dans le cas de l'utilisation de lien redondant.
Si une possibilité de boucle est détectée, un des ports du switch est bloqué.

C'est un protocole de niveau 2.
topologie spanning-tree
Par défaut le spanning-tree est actif sur le commutateur (mode pvst+). Il existe deux autres modes disponibles sur les commutateurs: rapid pvst+ basé sur le protocole 802.1w et MSTP basé sur le protocole 802.1s.

Dans certain cas, il est souhaitable de fixer les priorités par défaut.
Le switch qui aura la priorité la plus basse sera élu root. On choisit un switch qui est placé en tête du réseau (backbone) puisque tout le traffic passe par lui et qu'en général, il n'y a pas beaucoup de machine cliente connectée.
De plus, on peut préférer un lien par rapport à un autre, pour des raisons de débit différent par exemple.

La priorité par défaut d'un switch est de 32768. La priorité d'un port par défaut est 128. Si on abaisse le chiffre, le switch ou le port devient prioritaire par rapport aux autres.

Activation du rapid spanning-tree sur le switch

2960-RG(config)#spanning-tree mode rapid-pvst

Vérification des informations

2960-RG#sh spanning-tree

VLAN0001
Spanning tree enabled protocol rstp
Root ID Priority 28673
Address 0008.e4ff.ec11
Cost 23
Port 9 (GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0026.4585.2100
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1 Root FWD 19 128.9 P2p
Il est possible, entre autre, de préciser une interface à la suite de la commmande sh spanning-tree.

Fixer le switch root

Dans la copie d'écran suivante le switch est root pour les vlans 1 à 100. Puis on affiche les données spanning-tree pour le vlan 4.
switch(config)#spanning-tree vlan 1-100 root primary
switch(config)#end
switch#show spanning-tree vlan 4

VLAN04
Spanning tree enabled protocol rstp
Root ID Priority 24726
Address 0026.525b.3500
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24726 (priority 24576 sys-id-ext 4)
Address 0026.525b.3500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/3 Desg FWD 19 128.3 P2p
Gi0/1 Desg FWD 19 128.9 P2p


switch#

Configurer une priorité sur un port

Dans l'exemple, l'interface prioritaire sera gi0/1 pour les vlans 1 à 100. On affiche ensuite les informations pour le vlan 4.
switch(config)#interface gigabitEthernet 0/1
switch(config-if)#spanning-tree vlan 1-100 port-priority 64
switch(config-if)#end
switch#show spanning-tree vlan 4

VLAN04
Spanning tree enabled protocol rstp
Root ID Priority 32918
Address 0008.e3de.fe32
Cost 23
Port 9 (GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32918 (priority 32768 sys-id-ext 4)
Address 0026.525b.3500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/3 Desg FWD 19 128.3 P2p
Gi0/1 Root FWD 19 64.9 P2p


switch#

Configuration des ports d'accès reliés à un switch

Lors du démarrage d'un switch, la recherche de la meilleure topologie prend un peu de temps. La commande suivante fait passer directement le port de l'état blocking à l'état forwarding, le démarrage de l'interface est donc plus rapide. On appliquera cette commande sur les ports reliés à des machines terminales (PC, imprimante, ...).

2960-RG(config)#int range fa0/1 - 8
2960-RG(config-if-range)#spanning-tree portfast
Vérification
2960-RG#sh run int fa0/1
Building configuration...

Current configuration : 107 bytes
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
spanning-tree portfast
end
Désactivation du spanning-tree portfast pour une interface puis vérification.

2960-RG(config)#int fa0/1
2960-RG(config-if)#no spanning-tree portfast
2960-RG(config-if)#end
2960-RG#sh run int fa0/1
Building configuration...

Current configuration : 83 bytes
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
end

2960-RG#



Recherche personnalisée